Facebook-Theme - Hintergrund-Datei wird nicht angezeigt | Forum

Position: Forum » Erweiterungen » Themes
Ranseier Mai 20
Hallo, ich habe das Facebook-Theme von Oxwall installiert. Es gibt nur ein Problem: Die beigefügte Hintergrundbild-Datei (Sign in background image) lässt sich nicht laden, stattdessen erscheint beim Startmenü (Anmeldung) ein weißer Bildschirm.

Bei anderen Themen, wo ich das Hintergrundbild tauschen kann, erscheint das neue Hintergrund sofort nach dem Neustart. Beim FB-Theme bleibt der Hintergrund weiß. Habe schon alles versucht.

Wer kann helfen? Danke.


So siehts aus:

Zuletzt bearbeitet von Ranseier Mai 20
Ranseier Mai 20


Das ist die Hintergrunddatei, die statt des weißen Hintergrunds erscheinen sollte. Sollte. Sie erscheint nicht. Das ist die Originaldatei, die im Paket dabei ist.

Zuletzt bearbeitet von Ranseier Mai 20
Team
Leo Mai 21

Bitte teile uns mit, welches Theme du genau meinst (Link zum Store).


Lässt sich das Bild mittels URL abrufen? Hast du bereits den Entwickler kontaktiert?


Zuletzt bearbeitet von Leo Mai 21
Ranseier Mai 22

@Leo: Das Problem ist das, dass das Thema bei roxwall gelistet war, und dort frei heruntergeladen werden konnte. Die Domain roxwall.com wurde wohl mittlerweile verkauft, dort sind jetzt Werbelinks drauf. Also keine Chance den Entwickler zu kontaktieren. Klicke ich im Bearbeitungsmenü auf die Grafik, und wähle dann "Hintergrundgrafik anzeigen", erscheint die URL auf meiner NAS. Und die stimmt.


Team
Leo Mai 23

Lässt sich das Bild mittels URL abrufen?


Bitte poste den Link zu der betreffenden Seite, damit wir es uns ansehen können. Danke.

Ranseier Mai 24
Wäre zwar ein Link zu meiner privaten Oxwall-Seite gewesen, den ich ungern hergebe, aber ich habe es eben geprüft, auf der Startseite kann ich bei "Seiteninformationen anzeigen" und dann bei "Menü" die Grafik per URL erkennen.
Team
Leo Mai 25
Bitte sende mir trotzdem deine URL per PN zu, dann kann ich mir das mal anschauen. Ich melde mich dann wieder hier, natürlich ohne Nennung der URL.
Ranseier Mai 25

Zitat von Leo Bitte sende mir trotzdem deine URL per PN zu, dann kann ich mir das mal anschauen. Ich melde mich dann wieder hier, natürlich ohne Nennung der URL.


Hallo Leo Du hast Post!


Team
Leo Mai 26

Das Hintergrundbild ist der Klasse "ow_sign_in_cont" zugeordnet, das macht hier keinen Sinn. Füge folgenden Code in deiner CSS-Datei hinzu und ersetze "<url>" durch die URL zu deinem Bild:


.ow.thefacebook.base_sign_in {
  background-image: url('<url>'); /** OW_Control type:image, key:sinbackgroundImage, section: 4. Sign In Page Settings, label: Sign in background image **/
  background-size: 100% 100%;
  background-attachment: fixed;
}


Danach sollte das Bild richtig angezeigt werden, wie im Anhang dargestellt. Durch den Control-Code kannst du es zukünfig über den Adminbereich bearbeiten. Dazu musst du aber noch den Control-Code in der Datei base.css von der Klasse "ow_sign_in_cont" entfernen, damit er nicht doppelt vorhanden ist.


Du hast außerdem noch eine Inline-Regel, die einen weißen Hintergrund erzeugt. Die musst du ggf. ausblenden, falls das Hintergrundbild nach dem Hinzufügen der Regel nicht angezeigt wird.

Zuletzt bearbeitet von Leo Mai 26
Anhänge:
  bg.jpg (443Kb)
Ranseier Mai 27

Hallo Leo, Danke erstmal für die Tips.

Habe den o.g. Code eingefügt und entsprechend angepasst. Beim Einloggen bleibt der Hintergrund weiß :(


Was ist mit Control-Code bei der Klasse "ow_sign_in_cont" gemeint, welcher Abschnitt?


Hab das hier mal angeheftet.

/* ---- SignIn Form styles ---- */
.ow.thefacebook.base_sign_in {
  background-image: url('http://www.yourwebsite.com/...emes/theme_image.jpg');/** OW_Control type:image, key:sinbackgroundImage, section: 4. Sign In Page Settings, label: Sign in background image **/
  background-size: 100% 100%;
  background-attachment: fixed;
}
.ow_sign_in_cont {
    width:100%;
    height:100%;
    position:absolute;
    top:0;
    left:0;
    z-index:97;


Zuletzt bearbeitet von Ranseier Mai 31
Team
Leo Jun 1

Hast du den OW_DEV_MODE in der Datei /ow_includes/config.php aktiviert, bevor du die Änderungen eingepflegt hast? Ich kann aktuell nicht erkennen, dass die CSS-Regeln so wie von die beschrieben ausgeliefert werden. Es kommen weiterhin die alten Regeln zur Anwendung.


Die Regeln selbst stimmen, so wie du sie gepostet hast.

Zuletzt bearbeitet von Leo Jun 1
Ranseier Jun 1

Zitat von Leo

Hast du den OW_DEV_MODE in der Datei /ow_includes/config.php aktiviert, bevor du die Änderungen eingepflegt hast? Ich kann aktuell nicht erkennen, dass die CSS-Regeln so wie von die beschrieben ausgeliefert werden. Es kommen weiterhin die alten Regeln zur Anwendung.


Die Regeln selbst stimmen, so wie du sie gepostet hast.


Nein, war auf "false" - ist jetzt auf "true".


Das Hintergrundbild ist nun da, aber nun habe ich folgende Meldung:

Message: The each() function is deprecated. This message will be suppressed on further calls File: /volume1/web/oxwall/ow_libraries/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php Line: 78


Nachtrag: Auch dieser Fehler wurde behoben, ich habe eine gültige Datei gefunden, und die alte Datei ersetzt.


Dann noch den Link zum Logo im Abschnitt "SignIn form Styles" geändert- Bis auf ein kleines Mamko ist nun alles top: Wie ändere ich die Größe des Logos?



Zuletzt bearbeitet von Ranseier Jun 1
Team
Leo Jun 1
Indem du ein größeres Logo hochlädst und ggf. in Zeile 5223 deiner Datei base.css die font-size änderst.
Ranseier Jun 1

Hallo Leo, das hat geklappt, und dann noch in Zeile 5224 "line-height" entsprechend anpassen.


Danke für die Unterstützung. Ist zwar grad langsam beim Laden und Anmelden, aber okay.

So siehts jetzt aus