kein Update von 1.8.3 auf 1.8.4 möglich | Forum

blecky Feb 22 '17
Hallo,
ich habe jetzt alles neu aufgesetzt installiert usw. System läuft auch. Nur wenn ich Aktualisieren möchte auf 1.8.4 erscheint  danach:
500 Internal Server Error
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@XXXXXXX.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


Dann muss ich das Backup einspielen und das wars....

blecky Feb 22 '17
Das sind die Daten aus der Error_log

[22-Feb-2017 12:03:38 UTC] PHP Fatal error:  Undefined class constant 'LANG_ID_VAR_NAME' in /home/xxxxxxxxx/public_html/ow_core/application.php on line 779
[22-Feb-2017 12:03:38 UTC] PHP Stack trace:
[22-Feb-2017 12:03:38 UTC] PHP   1. {main}() /home/xxxxxxxxxx/public_html/index.php:0
[22-Feb-2017 12:03:38 UTC] PHP   2. OW_Application->init() /home/xxxxxxxxx/public_html/index.php:54
[22-Feb-2017 12:03:38 UTC] PHP   3. OW_Application->detectLanguage() /home/xxxxxxxx/public_html/ow_core/application.php:98
Team
Leo Feb 22 '17
Unterstützt dein Server alle Voraussetzungen, insbesondere die erforderliche PHP-Version?

Hast du das Upgrade automatisch oder manuell durchgeführt?
Zuletzt bearbeitet von Leo Feb 22 '17
blecky Feb 22 '17
Also das ganze fing an bei den Updates von 1.81.auf 1.82. auf 1.8.3, da musste ich von php 4.5 auf 5.6 umschalten. Danach tauchte immer das selbe Problem auf. Die Voraussetzungen sind da und der Hoster bietet auf seinen Servern auch Oxwall an.
Das Update habe ich automatisch ausgeführt.
Ich hänge mal Fotos meiner PHP-Einstellungen an, ich bin mir Sicher es fehlt nur irgendwo ein Häckchen, weiß aber leider nicht wo....
Anhänge:
  php3.PNG (37Kb)
  php1.PNG (20Kb)
  php2.PNG (17Kb)
blecky Feb 22 '17
So ich habe mal noch schnell eine PHPInfo hochgeladen und im Anhang das Ergebnis
Anhänge:
  php5.PNG (28Kb)
  php4.PNG (66Kb)
Team
Leo Feb 23 '17
Sofern die Voraussetzungen gegeben sind, bitte ich dich, ein manuelles Upgrade vorzunehmen. Teile im Anschluss bitte mit, ob das Problem weiterhin besteht.

Eine Anleitung dazu findest du unter https://wiki.oxwall.com/install:update#manual-update1.
blecky Feb 24 '17
Hallo,
in welches verzeichnis muss der Ordner ow_core_update_pack_1.8.4.1
Ich habe ihn via ftp hochgeladen ins Hauptverzeichnis und wenn ich ow_updates aufrufe kommt siehe Anhang.
Anhänge:
  meldung.PNG (3Kb)
Team
Leo Feb 24 '17
Der genaue Updateprozess steht auf der Seite beschrieben, die ich zuvor genannt habe. Demnach muss der Inhalt des zip-Archivs in das Root-Verzeichnis geladen und anschließend die Seite deine-url.tld/ow_updates aufgerufen werden.

Ein Upgrade auf eine höhere Version kann natürlich nur mit einer kleineren Version korrekt erfolgen. Dementsprechend darfst du nicht von deiner 1.8.4-Installation ausgehen, sondern musst das Upgrade auf die 1.8.3-Installation anwenden.
blecky Feb 25 '17
So nun ist es vollbracht und manchmal steht man eben voll auf dem Schlauch.
Daher auch mal zum Verständnis dieses Thema hier.
Der Inhalt des Zip-Archivs ist wiederum auch ein entpckter Ordner mit der Bezeichnung
ow_core_update_pack_1.8.4.1
Und dann kommt erst der wichtige Inhalt. Da ich etwas auf dem Schlauch stand stellte ich ja die Frage wohin mit diesem Ordner?
Nun gut, den Inhalt ins Stammverzeichnis hochgeladen und alle Ordner und Dateien überschrieben, sollte bei so einer Fragestellung auch wenn sie evtl. nervt vielleicht erwähnt werden, ow_updates aufgerufen und JA super es hat geklappt mit der manuellen Aktualisierung.
Was mir noch aufgefallen ist, das automatische Serverbackup veändert wieder die Dateiberechtigungen und setzt alle Ordner auf 755.
Jedenfalls ist jetzt alles Aktuell, was aber noch nicht beantwortet warum das automatische Aktualisieren nicht funktioniert. Aber auch nur bei der Kernaktualisierung, die Plugins konnte ich wiederum automatisch aktualisieren.


Team
Leo Feb 25 '17

Zitat von blecky das automatische Serverbackup veändert wieder die Dateiberechtigungen und setzt alle Ordner auf 755.
Bitte wende dich dazu an deinen Hosting-Provider. Das Anlegen eines Backups liegt immer im Verantwortungsbereich des Providers und nicht von Oxwall.


Zitat von blecky was aber noch nicht beantwortet warum das automatische Aktualisieren nicht funktioniert. Aber auch nur bei der Kernaktualisierung, die Plugins konnte ich wiederum automatisch aktualisieren.
Wie bei jeder Veröffentlichung im Oxwall-Blog erläutert wird, muss das Plattform-Upgrade vor der Aktualisierung der Plugins oder Themes erfolgen. Nur so ist gewährleistet, dass alle Funktionen fehlerfrei zur Verfügung stehen.