SSL und Videos | Forum

gami1976 Sep 24 '15
Hallo,


ich habe ein Problem seit kurzem nutze ich SSL und habe jetzt das Problem das keine Videos mehr angezeigt  werden, (Einbettende)  diese werden jetzt auch mit https ersetzt. wer kann mir bitte helfen??


Danke



Team
Leo Okt 10 '15
Oxwall ist zu 100% HTTPS-kompatibel. Um welche Video-Provider handelt es sich?
giro21 Jan 26 '17
z.B. (*Seitenname von der Administration entfernt*). Wenn ich SSL ausschalte dann funktioniert alles gut, mit SSL leider nicht.
Zuletzt bearbeitet von Leo Jan 26 '17
Team
Leo Jan 26 '17
Unterstützt der Video-Provider die Einbindung von Videos mittels SSL? Hast du eine Content Security Policy (CSP), die ein Einbinden mittels SSL verhindert?
giro21 Jan 28 '17
Der Embed-Code besagter Seite wird ohne SSL ausgegeben als http. Wenn ich in dem Embed-Code ein "s" hinzufüge, lassen sich die Videos abspielen. Allerdings wird auch so kein Vorschaubild angezeigt.

Was ist das "Hast du eine Content Security Policy (CSP)" wo kann ich das einstellen?
Team
Leo Jan 28 '17
Bitte erkundige dich beim Provider, ob es in Bezug auf das Abspielen von Videos bzw. Anzeigen der Vorschaubilder Blockaden gibt.

Zitat von giro21
Was ist das "Hast du eine Content Security Policy (CSP)" wo kann ich das einstellen?
Dabei handelt es sich um einen HTTP-Header, den du manuell hinzugefügt haben musst, z.B. über die htaccess-Datei. Er dient dazu, referenzierte Inhalte nur von den angegebenen Quellen zu erlauben.
Zuletzt bearbeitet von Leo Jan 28 '17
giro21 Jan 28 '17
Ich habe das ganze noch mal bei einem anderen Provider getestet. Wenn Oxwall mit https läuft lassen sich nur https Videos einbinden.

(Habe das bei dem Empfohlenen Hoster FastComet (https://developers.oxwall.com/hosting) getestet. )

Vorschaubilder werden nur bei YouTube und Dailymotion angezeigt. z.B. bei Vimeo oder Metacafe gibt es keine Thumbnails.

Gibt es eine Möglichkeit alle Videoquellen zu erlauben?
Zuletzt bearbeitet von giro21 Jan 30 '17
Team
Leo Jan 28 '17
Im Administrationsbereich kannst du "Einstellungen" -> "Benutzer-Einstellungen" -> "Inhalte" -> "Media-Funktionen" die verschiedenen Provider eingeben.
Zuletzt bearbeitet von Leo Jan 28 '17
giro21 Jan 30 '17

Zitat von Leo Im Administrationsbereich kannst du "Einstellungen" -> "Benutzer-Einstellungen" -> "Inhalte" -> "Media-Funktionen" die verschiedenen Provider eingeben.

Ja, das ist bekannt. Man kennt ja aber nicht alle Provider. Es wäre gut, wenn man keinen selektieren müsste und alle würden funktionieren.
giro21 Jan 30 '17

Zitat von giro21 Ich habe das ganze noch mal bei einem anderen Provider getestet. Wenn Oxwall mit https läuft lassen sich nur https Videos einbinden.

(Habe das bei dem Empfohlenen Hoster FastComet (https://developers.oxwall.com/hosting) getestet. )

Vorschaubilder werden nur bei YouTube und Dailymotion angezeigt. z.B. bei Vimeo oder Metacafe gibt es keine Thumbnails.

Gibt es eine Möglichkeit alle Videoquellen zu erlauben?

Keiner dazu eine Idee?
Team
Leo Jan 30 '17
Aktuell gibt es keine Möglichkeit, alle Provider zu erlauben. Sie müssen alle einzeln hinzugefügt werden.