SSL unter Oxwall | Forum

Position: Forum » Support » Konfiguration
Outperformer Okt 23
Seit dem ich SSL auf meiner Seite eingeführt, meckert Firefox, dass teilweise Grafiken unsicher sein könnten. Lässt sich das irgendwie beheben? Ist ja eigentlich nicht schlimm, aber da kommt immer so ein gelbes Warndreieck. Gruß
Anhänge:
  Unbenannt3.JPG (8Kb)
Team
Leo Okt 23

Zitat von Outperformer Ist ja eigentlich nicht schlimm
Das ist insofern schlimm, als dass dann nicht alle Elemente deiner Website verschlüsselt ausgeliefert werden und z.B. ein Dritter Anfragen auf solche Elemente mitlesen und ggf. modifizieren kann (vgl. https://support.mozilla.org/de/kb/Wie-beeinflussen-Inhalte-die-nicht-sicher-sind-meine-Sicherheit).

Um das zu vermeiden, musst du in Wesentlichen folgende Punkte überprüfen:

1. Hast du in deinen CSS-Dateien auf Bilder durch Angabe eines unverschlüsselten, absoluten Pfades (https://...) verwiesen? Füge in diesem Fall einfach ein s für https:// ein, um die Bilder über eine sichere Verbindung zu laden.

2. Sind in deiner Datenbank absolute Verweise vorhanden (einfach mal nach deiner URL inklusive https://(www)... suchen)? Auch in diesem Fall entsprechend ersetzen (vgl. oben).
Outperformer Okt 23
Mmmh, also in der css ist alles mit ... drin. In der Datenbank konnte ich 5x in ... ändern, aber er das Dreieck erscheint immer noch. Hättest Du sonst noch einen Ordner, wo ich gucken könnte? Danke.
Outperformer Okt 24
Obwohl ich hatte jetzt nur in der Theme-css geguckt. Wie kann ich denn z.B. mit Filezilla alle css Inhalte prüfen? Geht das?
Outperformer Okt 24
Könnte es auch so etwas sein:

url("data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A//www.w3.org/2000/

? und dann http durch https ersetzen?
Outperformer Okt 24
Der Übeltäter scheint eine 301 Weiterleitung auf https zu sein. Aber ich kann bei meinem Host nichts anderes als die Weiterleitung einstellen, um https zu bekommen. 302 zu Testzwecken geht noch.
Anhänge:
  Unbenannt4.JPG (16Kb)
Outperformer Okt 24
Habe jetzt in der Datenbank alle Einträge mit https://www.(meineseite).de ersetzt, insbesondere die alten Einträge. Hoffe, das ist nicht negativ für meine Seite. Resultat ist null, immer noch wie vorher.
Team
Leo Okt 24
Klicke mal auf das grüne Schlosssymbol in Firefox -> Rechter Pfeil -> Weitere Informationen -> Medien. Die obere Box zeigt dir anschließend alle Mediendateien an, dort kannst du auch erkennen, welche Grafiken unverschlüsselt ausgeliefert werden. Je nachdem kannst du dann weiter analysieren, woher die Grafiken stammen.
Outperformer Okt 24
Habe es gelöst - hurra. Habe tatsächlich in drei .css Dateien vom Theme was gefunden.

Danke nochmals, Leo.
Outperformer Okt 24
unter ow.userfiles
Outperformer Okt 24
aber dass ich jetzt in der Datenbank rumgemacht habe, macht nichts, oder?
Team
Leo Okt 24

Zitat von Outperformer aber dass ich jetzt in der Datenbank rumgemacht habe, macht nichts, oder?
Solange du nur Links von HTTP auf HTTPS umgestellt hast, gibt es keine Probleme. Du hast dadurch nur einen Mehrwert, denn anstatt eine unnötige Weiterleitung von HTTP nach HTTPS zu bewirken, werden deine Benutzer direkt auf die verschlüsselte Variante geleitet. Voraussetzung ist natürlich, dass du das SSL-Zertifikat periodisch verlängerst bzw. durch deinen Anbieter verlängern lässt.